Studio - Dynamic Image Latency

Incident Report for Movable Ink

Postmortem

Incident Summary

On Thursday, October 2nd, 2025 between 11:35 AM and 2:50PM EDT and again between 3:05PM EDT and 5:15 PM EDT, the Studio platform experienced degraded performance during which customers could have experienced slow loading or failure to load dynamic campaign assets in our US data centers.

Resolution

On-call engineers were engaged during both incident windows and after investigation it was determined that the first degraded performance window was due to a downstream service's scaling configuration change as part of a recent service release, which resulted in increased latency to upstream services. Once the issue was identified, Engineering initiated a rollback of the scaling configuration change which resulted in the restoration of normal dynamic campaign asset rendering performance.

The second degraded performance window was due to a rate limiting issue within the platform during autoscaling of the dynamic campaign asset service. Once the issue was identified, Engineers initiated a scale in of resources to mitigate the rate limiting issue and normal dynamic campaign asset rendering performance was restored.

Corrective Actions

Engineering has improved the process around autoscaling configuration changes, along with introducing an update to further mitigate the likelihood of the rate limiting that was encountered from occurring again.

Posted Oct 07, 2025 - 17:53 EDT

Resolved

Between the hours of 11:35AM and 2:50PM PDT on October 2nd 2025, our US West data centre region encountered issues with dynamic images having an increased latency in image loads which could have potentially caused images to fail to render.
Our on call engineers were able to resolve the issue.
Please reach out to the Technical Support team if you continue to see this issue or have additional questions. A post-mortem will be posted within 7 business days.
Posted Oct 03, 2025 - 11:12 EDT