The login issues affecting the Studio platform have been fully resolved. Users should now be able to login into their accounts as normal. Please reach out to the Technical Support team if you continue to see this issue or have additional questions. A post-mortem will be posted within 7 business days.
Posted May 12, 2026 - 18:22 EDT
Monitoring
Engineering has pushed a quick fix, and users are now able to log in successfully. We are continuing to monitor and will share the next update in 60 minutes.
Posted May 12, 2026 - 16:51 EDT
Update
We are continuing to investigate login issues affecting the Movable Ink platform. Our Engineering team is still investigating the root cause. We will post another update in 60 minutes.
Posted May 12, 2026 - 15:13 EDT
Investigating
Users may be experiencing trouble logging into the Movable Ink platform. Our Engineering team is currently investigating. We will post an update in 60 minutes.