Studio - Dynamic Links Routing to Fallback Destinations

Incident Report for Movable Ink

Postmortem

Incident Summary

Between the hours of 12:51 PM EST and 1:55 PM EST on Monday January 12th, 2026, some Studio customers may have experienced dynamic links routing to fallback destinations. The event was caused by a new configuration of our core router which was not set up correctly for serving dynamic links requests.

Resolution

Once the fallback behavior was reported to Engineering by Technical Support, the Engineers were quickly able to pinpoint the behavior to a deployment from that day. The remedial configuration was first tested in an isolated data center, and after verifying that dynamic links were working again it was deployed to all other datacenters. This restored expected dynamic link behavior.

Corrective Actions

In order to prevent similar issues from occurring in the future:

  • The change has been committed to source code.
  • The new deployment architecture will support more dynamic scaling of our core router.
Posted Jan 15, 2026 - 17:15 EST

Resolved

Between 12:51 PM EST and 1:55 PM EST on January 12, 2026, dynamic links in some campaigns were routing to fallback destinations. The issue has been resolved and links are now routing to their expected destinations.

If you continue to experience this issue or have additional questions, please reach out to Technical Support. A post-mortem will be published within 7 business days.
Posted Jan 12, 2026 - 14:13 EST
This incident affected: Studio (Dynamic Links).