Studio - CSV Active Integrations Failing to Update/Upload

Incident Report for Movable Ink

Postmortem

Incident Summary

Between the hours of 6:12PM and 6:51PM ET on Tuesday, January 6th, Studio users may have experienced issues with CSV active integrations (data sources). A change was deployed to production intended to improve CSV ingestion performance which inadvertently exposed a previously unidentified permissioning issue in production storage. This caused CSV ingestion failures. Once the change was fully reverted normal CSV processing resumed. No data loss occurred during this time, and no other data ingestion paths were affected.

Resolution

The deployed change introduced new file handling behavior that interacted with production storage permissions in an unexpected way. These permission constraints were not present or enforced in local development environments, preventing detection during pre-deployment testing. Once CSV ingestion errors were detected in production, Engineers were able to trace the issue to storage permission constraints added as a result of the deployment. Once the deployment was reverted to the previous stable version, expected CSV ingestion behavior was immediately restored.

Corrective Actions

In order to prevent similar events from occurring in the future, our Engineering team is working to bring our staging environment to functional parity with production.

Posted Jan 15, 2026 - 17:08 EST

Resolved

The issue regarding CSV Active Integrations has been resolved. Please reach out to the Technical Support team if you continue to see this issue or have additional questions. A post-mortem will be posted within 7 business days.
Posted Jan 06, 2026 - 18:51 EST

Investigating

Users may be experiencing trouble with the CSV Active Integrations (Data Sources) feature. The issue is presenting itself as failed data updates for existing CSVs Integrations and empty CSV Integrations for net new Active Integrations. Our Engineering team is currently investigating. We will post an update in 24 hours.
Posted Jan 06, 2026 - 18:12 EST
This incident affected: Studio (Active Integrations).