Studio - Content Rendering & Delayed Reports

Incident Report for Movable Ink

Postmortem

Incident Summary
On Monday October 20th, 2025 between 3:10 AM and 6:40 AM EDT, the Studio platform experienced degraded performance during which customers could have experienced slow loading or failure to load dynamic campaign assets out of our US East datacenter. Separately, between 8:28 AM and 11:03 PM EDT, reporting and analytics features within the Studio platform were unavailable.

Resolution
On-call engineers were engaged immediately and it was determined that degraded performance was due to a combination of regional and global service unavailability within our cloud service provider US East datacenter. Once this issue was identified, engineers attempted to shift all traffic away from our US East datacenter to our US West datacenter and raised a high priority issue with our cloud service provider’s technical support team. Due to the underlying issues within our cloud service provider, repeated attempts failed until 6:30 AM EDT with a full failover of US East traffic to US West completed at 6:40 AM EDT. Once this failover was completed, error rates within the platform dropped off and content serving was restored to normal performance.

As service provider issues persisted, on-call engineers were again engaged regarding availability of reporting and analytics. A separate high priority issue was raised to cloud service provider support, who determined that this issue was directly related to the ongoing service provider issues. The data and site reliability teams continued to monitor the situation with the service provider throughout the day and as the situation gradually resolved it was determined at 5:15 PM EDT that the site reliability team could begin sending a portion of traffic back to US East. US East was again serving normal traffic load by 5:45 PM EDT, restoring normal operations of load shared between US datacenters.

Reporting and analytics underlying systems were not restored until 11:03 PM EDT at which point historical data was available, but the prior day's data had not been successfully processed and remained unavailable. Reporting systems continued to process backlogs through EOD Thursday October 23rd, 2025 at which point the backlog was fully processed.

Corrective Actions
This was a result of a one-off, global service unavailability disruption within our cloud service provider in the US East datacenter, and there are no corrective actions to be taken to prevent recurrence.

Posted Oct 27, 2025 - 17:14 EDT

Resolved

The issue regarding Studio content rendering and delayed reporting has been resolved. Please reach out to the Technical Support team if you continue to see this issue or have additional questions. A post-mortem will be posted within 7 business days.
Posted Oct 23, 2025 - 13:09 EDT

Update

The backlog of delayed reports is continuing to be processed. We will be closely monitoring to ensure the data is fully backfilled. Another update will be posted by 6PM PDT tomorrow, Thursday October 23rd.
Posted Oct 22, 2025 - 20:34 EDT

Update

The backlog of delayed reports is continuing to be processed. We will be closely monitoring to ensure the data is fully backfilled. Another update will be posted by 6PM PDT tomorrow, Wednesday October 22nd.
Posted Oct 21, 2025 - 18:10 EDT

Monitoring

The disruption from our upstream provider is now resolved, the backlog of delayed reports are now being processed.

We will continue monitoring to ensure the data is fully backfilled. We will post another update by 6pm ET.
Posted Oct 21, 2025 - 09:40 EDT

Update

We are continuing to experience delays in report generation, including Analytics Explorer, Data Exports, and in-platform reporting as we await our upstream provider to come fully back online and then process our backlog of data. Our team is monitoring the situation, and we will post another update by 6PM PDT tomorrow, Tuesday October 21st.
Posted Oct 20, 2025 - 19:40 EDT

Update

We are continuing to experience delays in report generation, including Analytics Explorer, Data Exports, and in-platform reporting. Our team is monitoring the situation. We will post another update by 6PM PDT.
Posted Oct 20, 2025 - 15:58 EDT

Update

We are still experiencing delays in report generation, including Analytics Explorer, Data Exports, and in-platform reporting. Our team is continuing to monitor the situation. We will post another update in 2 hours.
Posted Oct 20, 2025 - 13:44 EDT

Update

We are still experiencing delays in report generation, including Analytics Explorer, Data Exports, and in-platform reporting. Our team is continuing to monitor the situation. We will post another update in 1 hour.
Posted Oct 20, 2025 - 12:14 EDT

Identified

We experienced a service disruption from one of our upstream providers between 4:00 AM ET and 5:45 AM ET, which may have caused some users to see fallback images in place of content.

In addition, there are currently delays in report generation, including Analytics Explorer, Data Exports, and in-platform reporting.

Our team is actively monitoring the situation. We will post an update in 1 hour.
Posted Oct 20, 2025 - 10:25 EDT
This incident affected: Studio (Content Rendering, Analytics).