Da Vinci - Campaigns Stuck in Varying Stages

Incident Report for Movable Ink

Postmortem

Incident Summary

On Friday, November 21st, the Da Vinci Engineering team noticed delayed processing of tasks from one of our background worker pools, and made a change to increase the scaling limits associated with those pools, as well as immediately scaling up resources to clear the backlog and ensure that plenty of workers would be in place for campaign preparation. However, a misconfiguration in the resource allocation policies for that worker pool caused the resources to shrink back to original levels over time instead of remaining at the increased levels, while still keeping the worker count high, leaving insufficient resources to be shared by that number of workers. This also caused downstream issues on Tuesday, November 25th (incident here), with similar behavior observed of some campaigns being stuck in the “syncing” or “scheduling” stages.

Resolution

The incident was resolved by fixing the resource allocation policies to ensure that each worker had sufficient resources to operate effectively, and will continue to operate smoothly going forward.

Corrective Actions

The Engineering team is auditing the resource allocation policies for all other internal applications to ensure that they will not run into similar issues when scaling.

Posted Dec 01, 2025 - 16:50 EST

Resolved

The issue with campaigns becoming stuck in a stage has been resolved. Please reach out to the Technical Support team if you continue to see this issue or have additional questions. A post-mortem will be posted within 7 business days.
Posted Nov 21, 2025 - 19:12 EST

Monitoring

A fix has been implemented, and campaign transitions should now be functioning as expected. We will continue monitoring to ensure the issue is fully resolved and will share another update within the next hour.
Posted Nov 21, 2025 - 17:38 EST

Investigating

Users may be experiencing trouble with their Da Vinci Campaigns being stuck in various stages. Our Engineering team is currently investigating. We will post an update in 1 hour.
Posted Nov 21, 2025 - 17:13 EST
This incident affected: Da Vinci (Web App).